Commit c85fd723 authored by Alexander A. Maly's avatar Alexander A. Maly

Setting minimal MAC OS deployment target to 10.9

We cannot set it to any earlier version because of strange libstdc++ behaviour.
So for now setting to 10.9 just to know how old versions we can support.
parent 499f0c56
Pipeline #1283 passed with stages
in 3 minutes and 6 seconds
...@@ -160,6 +160,7 @@ build:mac: ...@@ -160,6 +160,7 @@ build:mac:
- mkdir build - mkdir build
- cd build - cd build
- export PATH=$QTDIR_MAC/bin:$PATH - export PATH=$QTDIR_MAC/bin:$PATH
- export MACOSX_DEPLOYMENT_TARGET=10.9
- date - date
- cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DUSE_QT=5 -DCMAKE_BUILD_TYPE=Release .. - cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DUSE_QT=5 -DCMAKE_BUILD_TYPE=Release ..
- make -k -j8 - make -k -j8
...@@ -178,6 +179,7 @@ dist:mac: ...@@ -178,6 +179,7 @@ dist:mac:
script: script:
- cd build - cd build
- export PATH=$QTDIR_MAC/bin:$PATH - export PATH=$QTDIR_MAC/bin:$PATH
- export MACOSX_DEPLOYMENT_TARGET=10.9
- macdeployqt Kumir.app - macdeployqt Kumir.app
- echo "Libraries = Frameworks" >> Kumir.app/Contents/Resources/qt.conf - echo "Libraries = Frameworks" >> Kumir.app/Contents/Resources/qt.conf
- macdeployqt Kumir.app -dmg - macdeployqt Kumir.app -dmg
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment